2016年03月19日

MOD作成4

とりあえず動作するものができたので、リリース用jarファイルを作成する。

しかし、ここでハマった・・。

「エラー: ダイヤモンド演算子は-source 1.6でサポートされていません」
うんたらかんたら・・・。

ログを見ると
「-source 1.6 -target 1.6」
確かにそうなっていて、これを「-source 7 -target 7」にすれば良いとGoogle先生は言っている。

Androidアプリ系の事例はあるが、Minecraft系は全く無し。Wikiにもないっぽい。
build.xmlに指定するとのことだが、今の開発環境には存在しない。

唯一設定ファイルと思われるのはbuild.gradle。これで調べると・・・あった!
Gradle使い方メモ
[ソース・class ファイルの JDK バージョンを指定する]

これで解決。とおもいきやエラー多発。
シンボルが見つからない云々。つまり外部リンクができていないと。
こっちはModding Wikiに対処が書いてあった。(上記リンクも参考になる)

これでようやくコンパイルできた。実行環境で検証中。
posted by 騎士長 at 23:00| 日記